SBT Jetski Engines, Parts & Accessories

Results 1 to 3 of 3

Thread: MIss?

  1. #1
    Joined
    Aug 2003
    From
    Michigan
    Posts
    16

    Post

    I have a 2000 1100stxdi with a intermin miss. I have had this problem since new, on and off. Only under load. Anyone see this?

  2. #2
    Joined
    Mar 2003
    From
    SBT
    Posts
    21,555

    Post

    Have your dealer test your injectors, you may need a new one.
    SBT Tech Support is here to help with your problems.
    We try to answer each question quickly and accurately.
    Please do not use Private Messaging for Tech Support, use the forums.

  3. #3
    Joined
    Aug 2003
    From
    Michigan
    Posts
    16

    Post

    Is this a problem that you have seen?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. engine miss
    By ron wallace in forum Sea-Doo
    Replies: 2
    Last Post: 10-24-2007, 02:56 PM
  2. SLT 700 miss
    By adam250f in forum Polaris
    Replies: 2
    Last Post: 08-22-2007, 11:12 PM
  3. Hi speed miss...
    By Johnny-mike in forum Yamaha
    Replies: 0
    Last Post: 02-15-2007, 07:33 PM
  4. 99 GTX Ltd. and 97 GSX Miss
    By wpruitt in forum Sea-Doo
    Replies: 10
    Last Post: 09-26-2005, 02:16 PM
  5. Miss when accelerating
    By TXI MAn in forum Polaris
    Replies: 2
    Last Post: 06-01-2004, 11:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •