SBT Jetski Engines, Parts & Accessories

Results 1 to 5 of 5
  1. #1
    Joined
    Aug 2003
    From
    Canada
    Posts
    37

    Post

    Hey All,

    Well after last weeks compression nightmare I yanked the new head and slapped the stock one back on *sigh*. It looks like it was the right thing to do though...after 1 ride the pistons and domes were black (they were nice and shiny before the high comp. head)...and there were signs of hot spots on the tops of the pistons.

    So on to the new problem ;)

    I also swapped out the stock stinger cone for a longer one (about 3" longer). The ski starts fine, but at about mid throttle or higher it bogs down and dies..FAST. Now last summer this happened due to an exhaust leak at the expansion chamber coupler (which I re-seated and tightened to fix).

    I yanked the cone again and made sure it was seated as best it could be (the ridge around the wide end that fits in groove in the rubber coupler has a lower profile than the stock cone)...then I tightened the hose clamps as tight as they'd go. Still the same problem. I went and got the soapy water and wiped it all around the head and all exhaust fittings I touched to check for leaks...nothing...no signs of bubbles...no exhaust smell...no smoke.

    So could this be a result of lower back pressue due to a larger expansion chamber (if so what kind of adjustment should I try). Or does it still sound like an exhaust leak and I just have to try harder? ;)

    Thanks in advance

    Cheers

  2. #2
    Joined
    Mar 2003
    From
    SBT
    Posts
    21,555

    Post

    Make sure your carbs are rich enough first
    SBT Tech Support is here to help with your problems.
    We try to answer each question quickly and accurately.
    Please do not use Private Messaging for Tech Support, use the forums.

  3. #3
    Joined
    Aug 2003
    From
    Canada
    Posts
    37

    Post

    Great....that's been suggested by someone else as well. I know it's probably a ballpark at best given every machine is different....but any idea how many turns to dial out the high end given the added long cone? Should the low speed jet need to be richened as well?

    I guess ultimately I'll just tweak it to see what works best...but a guideline is always nice ;)

    Thanks

  4. #4
    Joined
    Mar 2003
    From
    SBT
    Posts
    21,555

    Post

    we have the oem settings in our tech section
    SBT Tech Support is here to help with your problems.
    We try to answer each question quickly and accurately.
    Please do not use Private Messaging for Tech Support, use the forums.

  5. #5
    Joined
    Aug 2003
    From
    Canada
    Posts
    37

    Post

    Oh I know...I'm wondering how far beyond the oem settings given that I've added the longer cone...1/8 turn out...1/4 turn out...more?

    If it's just a per machine kinda thing...no worries...I'll just try 1/8" turns till it works or I run out of turns ;)

    Cheers

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 750 SSXI Exhaust Leak?
    By Jax in forum Kawasaki
    Replies: 4
    Last Post: 05-21-2006, 06:38 PM
  2. exhaust leak
    By frankey01 in forum Sea-Doo
    Replies: 25
    Last Post: 09-17-2004, 10:20 PM
  3. 94 750 Super Sport XI Exhaust Leak
    By porsch964 in forum Kawasaki
    Replies: 3
    Last Post: 08-04-2004, 09:23 PM
  4. 94 XP EXHAUST LEAK
    By bonne76 in forum Sea-Doo
    Replies: 1
    Last Post: 06-09-2003, 10:46 AM
  5. 97 SPX Exhaust Leak ??????
    By Bryan Glynn in forum Sea-Doo
    Replies: 4
    Last Post: 08-20-2002, 11:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •