SBT Jetski Engines, Parts & Accessories

Results 1 to 3 of 3
  1. #1
    Joined
    Feb 2001
    From
    Lumberton, MS
    Posts
    25

    Default Hi-Temp/Low Oil Warning

    1998 Seadoo GTX.
    Proper ohms from oil sensor..1.6, open circuit is indication for low oil.
    Proper open circuit from temp sensor, closed circuit indicates high temp.
    Changed gauge with a new one, same problem.
    Changed mpem with a working unit from another unit, same problem.
    By unplugging the compass and fuel tank sending unit, the problem goes away and I get proper readings from temp and oil when induced.
    If compass is plugged in, Hi-temp/low oil warning is generated.
    Changed compass with a known good unit, problem is still generated
    If fuel sending unit is plugged in, Hi-temp/low oil warning is generated.
    Changed fuel sending unit with a known good unit, problem is still generated.
    Anyone have any suggestions, Seadoo dealer tech support while helpful, has not been able to solve the problem.
    Dave T.
    David B. Thomas<br />Blew-By-You PWC Services<br />93-A Pine Burr Rd<br />Lumberton, MS 39455

  2. #2
    Joined
    Feb 2001
    From
    Lumberton, MS
    Posts
    25

    Default Re: Hi-Temp/Low Oil Warning

    Follow-up
    There were two actual failures, one being the compass and the other being the gauge. When I changed out the gauge with a new one and got the same readings, it was assumed the old gauge was functioning properly and was re-installed. All components that were isolated was done using the old gauge.
    New gauge re-installed with the compass unplugged resulted in everything working properly.
    Hopefully this will help someone from killing a bunch of hours.
    David B. Thomas<br />Blew-By-You PWC Services<br />93-A Pine Burr Rd<br />Lumberton, MS 39455

  3. #3
    Joined
    Jul 2005
    From
    Raleigh NC
    Posts
    3

    Default Re: Hi-Temp/Low Oil Warning

    I have a 1998 GTX RFI I was jumping waves and this same problem happened to me. How do I troubleshoot and or fix the problem. I know everthing is ok with the TEMP and OIL. Any help would be great. Thanks in advance for the help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GTX 4-tec oil warning light and buzzer
    By Childo74 in forum Sea-Doo
    Replies: 1
    Last Post: 06-14-2006, 03:11 PM
  2. Replies: 2
    Last Post: 08-10-2005, 12:37 PM
  3. Oil warning light
    By grooveman in forum Yamaha
    Replies: 4
    Last Post: 07-28-2005, 03:52 PM
  4. oil warning light after block off kit
    By trenster in forum Kawasaki
    Replies: 9
    Last Post: 06-10-2005, 03:14 PM
  5. Oil Warning Gpr“s 800-1200
    By ArielARG in forum Yamaha
    Replies: 3
    Last Post: 01-14-2005, 02:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •