SBT Jetski Engines, Parts & Accessories

Results 1 to 5 of 5
  1. #1
    Joined
    Jul 2004
    From
    PA
    Posts
    37

    Default 98 ZXi 1100 idling problem

    I recently installed an SBT engine and have since run 7 tanks of gas through it trouble free....except I still have an idling problem. From reading other posts my problem seems to be opposite of others. It won't hold idle out of the water but idles absolutley perfect in the water. It also has no problems starting in or out of the water. When running it out of the water and revving the RPMs will rise and continue to rise before slowly coming back down and eventually shutting the engine down.
    The only thing I have not done is replace the fuel pump. Kawasaki makes you buy the entire pump. Could this be my problem? Getting kind of sick of the Trial and Error method with the overly expensive OEM carb parts!
    I have replaced diaphragms, gaskets, needles, seats, pop-off is 23 PSIG. I have also checked for air leaks around the reed cages, carb bases, crank, etc. and have found notta.
    BTW, the original engine failure was due to submerssion and the carbs in question are not the ones that were submerged.

    Thanks,
    SAH

  2. #2
    Joined
    Mar 2003
    From
    SBT
    Posts
    21,545

    Default Re: 98 ZXi 1100 idling problem

    So I take it you already rebuilt the carbs or had them done? That is symtomatic of a lean low-end, assuming your idle speed is not too high. It isn't going to be the fuel pump if it runs fine at top-end. It can only be a leak or leans low end in the carbs. Is the ski stock?
    SBT Tech Support is here to help with your problems.
    We try to answer each question quickly and accurately.
    Please do not use Private Messaging for Tech Support, use the forums.

  3. #3
    Joined
    Jul 2004
    From
    PA
    Posts
    37

    Default Re: 98 ZXi 1100 idling problem

    Yes, everything on the ski is stock. I rebuilt all three carbs before running out the first tank. I have the idle set at about 3500 out of the water which allows it to idle at about 1500 in the water. Any less than that and it will not idle in the water. Other than this problem is seems to be performing fine.

  4. #4
    Joined
    Mar 2003
    From
    SBT
    Posts
    21,545

    Default Re: 98 ZXi 1100 idling problem

    Well that tells you right there that you have a problem. Your idle is too high to begin with, but the fact that it won't idle at all less than that says FIX ME. You have something wrong in the carbs. What exactly have you done to them? Did you get rebuild kits from your dealer and replace EVERYTHING? Did you rebuild the slides too?
    SBT Tech Support is here to help with your problems.
    We try to answer each question quickly and accurately.
    Please do not use Private Messaging for Tech Support, use the forums.

  5. #5
    Joined
    Jul 2004
    From
    PA
    Posts
    37

    Default Re: 98 ZXi 1100 idling problem

    I realize there is a problem, which is why I am inquiring for suggestions for fixing it. Yes, all parts replaced were OEM. The only items I didn't replace are the vaccum slides and associated slide needle and spring. Could one or more of the tension springs be weak causing the slide to move too easily? Can the taper on the needle become too thin? I didn't think the vaccum slides played a role at idle speeds. Do they? I mean, are they intended to?

    Thanks,
    SAH

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kaw 1100 ZXi problem
    By jdsparks21 in forum Kawasaki
    Replies: 1
    Last Post: 08-23-2007, 12:59 PM
  2. 2000 Kawasaki 1100 zxi carb problem
    By Jenga in forum Kawasaki
    Replies: 3
    Last Post: 04-16-2006, 10:27 PM
  3. 98 1100 ZXI trim/gauge Problem
    By 98ZXIGUY in forum Kawasaki
    Replies: 0
    Last Post: 08-08-2005, 01:58 PM
  4. 99 ZXI 1100 problem
    By Fastmax32168 in forum Kawasaki
    Replies: 2
    Last Post: 08-13-2004, 03:39 PM
  5. 1996 1100 ZXI Problem
    By dhd in forum Kawasaki
    Replies: 6
    Last Post: 07-27-2004, 11:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •