SBT Jetski Engines, Parts & Accessories

Results 1 to 7 of 7
  1. #1
    Joined
    Nov 2004
    From
    Orlando FL
    Posts
    4

    Default Poor performance

    I have a 1996 Seadoo GSX that starts right up and idles fine. When I try to accelerate the ski will start to go and then die. Any ideas what the problem might be?

    Thanks

  2. #2
    Joined
    Feb 2004
    From
    New Jersey
    Posts
    2,601

    Default Re: Poor performance

    it could be many things , first do a compression check , if ok check your fuel system , you should pull your rear electric box and make sure its dry and pull your spark plug boots off and snip the wires back a little to show fresh wire then twist the caps back on ,
    PRIDE IN SERVICE<br /> <img src="http://www.sbtontheweb.com/images/forposts/4609/1.jpg" alt=" - " />

  3. #3
    Joined
    Nov 2003
    From
    Glendora, CA
    Posts
    6,846

    Default Re: Poor performance

    Did this just start happening all of the sudden, or has the gsx been worked on lately ? Did it run right before it started shutting down? Just out of storage?
    Tell us more about your GSX........
    Bill O'Neal <br>
    WCM
    <a href="http://www.watercraftmagic.com"

  4. #4
    Joined
    Nov 2004
    From
    Orlando FL
    Posts
    4

    Default Re: Poor performance

    I did a compression test, approx. 155 each cyl. The ski seems to have plenty of throttle when hooked up to a hose and starts right up. Will not go above idle when in the water.

    Thanks

  5. #5
    Joined
    Nov 2004
    From
    Orlando FL
    Posts
    4

    Default Re: Poor performance

    Sorry. This problem started after the ski sat for a couple of months.

  6. #6
    Joined
    Mar 2003
    From
    SBT
    Posts
    21,555

    Default Re: Poor performance

    I would start by getting a couple carb kits and rebuild them. Go through the fuel system as well as mentioned.
    SBT Tech Support is here to help with your problems.
    We try to answer each question quickly and accurately.
    Please do not use Private Messaging for Tech Support, use the forums.

  7. #7
    Joined
    Nov 2003
    From
    Glendora, CA
    Posts
    6,846

    Default Re: Poor performance

    You will most likely find one of the needles is stuck in it's seat inside the carb, or the diaphram is stuck to the jet cover. Rebuild the carbs.
    Bill O'Neal <br>
    WCM
    <a href="http://www.watercraftmagic.com"

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •