SBT Jetski Engines, Parts & Accessories

Results 1 to 5 of 5
  1. #1
    Joined
    Jul 2005
    From
    Waterford, MI
    Posts
    2

    Default 1999 TS 770R problem

    Dear All:

    I have a problem that I would like to share. The engine acts like it has no power or running on one cylinder. The engine stays at about 4500 RPM with the boat just getting on plane. Then if you hit a wave were the empeller sucks a little air for a second the engine takes off with full power and the boat is flying. Once you get this to happen the engine is fine and holds full power unless you slow down or stop again. I have changed plugs several times and ran Sea Foam through the system to no avail. The forward cylinder apears to be fine. If i had to guess the problem the rear cylinder. That plug is wet when removed.

    It is important to note that when the problem began I removed the old plugs and found the rear plug to have lead deposits around the ceramic portion and the gap to have mysterouly reduced to zero. I was almost releived to have seen this thinking I found the problem but to no avail.

    It feels like it is a spark problem the way it takes off all of a sudden when the prop takes a little air allowing the RPM to advance with no load.

    Please help, I have read all of the past posts with nothing like this posted. Thanks in advance for your input.

    Bruce
    Waterford, Michigan
    Elizabeth Lake

  2. #2
    Joined
    Jun 2002
    From
    Charlotte NC
    Posts
    1,868

    Default Re: 1999 TS 770R problem

    Check compression on both cylinders. Dirty carbs act like that or a cylinder with marginal compression.

    SeaFoam will not clean the carbs on jetski's you have to remove them and clean/rebuild. They have internal filters that get cloged over time. And parts that wear out.

    If compression is low on the rear cylinder check for a bad head gasket, you can order a new one here. If it is good the rebuild the carbs and change the fuel filter. Not a bad time to switch to premix.
    Providing mobile JetSki service to the Charlotte / Lake Wylie area.

  3. #3
    Joined
    Jul 2005
    From
    Waterford, MI
    Posts
    2

    Default Re: 1999 TS 770R problem

    Thanks for the quick resonce. I will get to work and check compression first and report back.


    Bruce

  4. #4
    Joined
    Feb 2001
    From
    Seattle area
    Posts
    142

    Default Re: 1999 TS 770R problem

    Make sure you are using NGK plugs. Sounds like low compression based on my personal experience.

  5. #5
    Joined
    Aug 2016
    From
    Kenosha, WI
    Posts
    1

    Default Re: 1999 TS 770R problem

    Somewhat the same issue, is it possible the temp sensor on the expansion chamber isn't working correctly?? I read somewhere if it's reading temp too high it shuts down one cylinder.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. XP Limited 1999 Battery draining problem
    By SpykeYs in forum Sea-Doo
    Replies: 2
    Last Post: 06-25-2012, 08:57 AM
  2. 1999 XLT1200 Starting Problem
    By hogheadjohnson in forum Yamaha
    Replies: 1
    Last Post: 03-04-2007, 05:38 PM
  3. 1999 seadoo gtx problem
    By hzoskiers2001 in forum Sea-Doo
    Replies: 5
    Last Post: 03-02-2007, 02:54 PM
  4. Tigershark TS 770R (1999) old shape - Cover ??
    By Jetski-junkie in forum Tigershark
    Replies: 9
    Last Post: 09-01-2005, 08:05 AM
  5. 1999 770r Tigershark Idle problems
    By yike98 in forum Tigershark
    Replies: 3
    Last Post: 07-17-2005, 08:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •