SBT Jetski Engines, Parts & Accessories

Results 1 to 1 of 1
  1. #1
    Joined
    Aug 2005
    From
    Northern NY
    Posts
    3

    Default Please help...

    I have a 1994 Kawaski 750 SS/XI...I has been running great until last weekend...One trip out it seemed to have several issues: starving for gas and battery issue...The battery was fine and fully charged and ran fine after that small episode...We also put new plugs in, again...It ran fine and like a charm this past Saturday, but Monday evening problems again...First it didn't want to start...and then quit in the middle of the water...I was told it acted like it was starving for gas...The plugs were sparking and dry...Once I got a rope attached from the Yamaha to the Kawasaki and was pulling it in, it was able to get running during that time...Everything has been pulled and checked on that machine and we seemed to have hit a brick wall....Any suggestions?

    Thanks
    Last edited by patti3336; 08-11-2005 at 10:27 AM. Reason: changing title

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 Tigershark TS640L Running Problems
    By 91seadoosp in forum Tigershark
    Replies: 1
    Last Post: 07-08-2007, 08:56 AM
  2. 2004 gp1300r running problems
    By td12682 in forum Yamaha
    Replies: 1
    Last Post: 07-19-2006, 10:25 PM
  3. 97 XP running problems
    By zephyr in forum Sea-Doo
    Replies: 1
    Last Post: 06-12-2006, 11:18 PM
  4. Replies: 2
    Last Post: 06-06-2005, 10:40 PM
  5. 1999 XL 760 starting, running problems
    By Millertime in forum Yamaha
    Replies: 2
    Last Post: 06-18-2002, 11:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •