SBT Jetski Engines, Parts & Accessories

Results 1 to 10 of 11

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Joined
    Jul 2005
    From
    Charleston, SC
    Posts
    16

    Default 99 GTX Ltd. and 97 GSX Miss

    Hey yall!
    Two problems a newb could use some advice on:

    1-99 GTX Ltd.--Miss/Hesitation out of the hole. Runs perfect otherwise.

    2-97 GSX (800)--Runs perfect except for strong miss from 3600-4600 rpm. Little low on top rpm's (6550). New SBT engine just thru break-in.

    Stock settings all around.

    Appreciate any advice.

    Warren

  2. #2
    Joined
    Nov 2003
    From
    Glendora, CA
    Posts
    6,846

    Default Re: 99 GTX Ltd. and 97 GSX Miss

    Anytime you have a miss in a Sea Doo engine, other than some on the newer models like the 4 strokes, you should first remove the sparkplug boots and clip the wires and reinstall the sparkplug boots. Many times, you will notice that the wire cores are mostly gone due to repeated arcing of the wires to the sparkplug boots.

    All rave valve motors surge at mid rpms, due to the rave valve fluctuating up and down as pressure spikes and drops in the exhaust ports or engine crankcases. Do not confuse this with an ignition problem.

    A hesitation from takeoff could indicate that the accellerator pump is not working properly, usllay because the brass nozzel(s) are clogged up. Or, maybe you just need to adjust the low speed adjusters a bit further out.
    Bill O'Neal <br>
    WCM
    <a href="http://www.watercraftmagic.com"

  3. #3
    Joined
    Jul 2005
    From
    Charleston, SC
    Posts
    16

    Default Re: 99 GTX Ltd. and 97 GSX Miss

    Thanks for the response Bill. The wires are new on the GSX so I assume they don't need to be clipped when new. I can certainly try to trim them and see if it helps.

    I would not consider what I am experiencing a surge. It feels like a miss but it is pretty strong. Is there a need or a way to calibrate or adjust the springs in the rave valves?

    Thanks,
    Warren

  4. #4
    Joined
    Nov 2003
    From
    Glendora, CA
    Posts
    6,846

    Default Re: 99 GTX Ltd. and 97 GSX Miss

    The red cap adjusters are there for your entertainment in tuning your ski, set them wherever you think they are doing the best for your motor. Up or down, they do not cause misses in the ignition.

    Misses are caused by fouled sparkplugs, bad sparkplug lead connections, bad coils, pickups or stator problems. A bad rectifier can emit some really bad RF interferences with the CDI. Make sure you have BR8ES sparkplugs, not B8ES.
    Bill O'Neal <br>
    WCM
    <a href="http://www.watercraftmagic.com"

  5. #5
    Joined
    May 2005
    From
    Canada
    Posts
    16

    Default Re: 99 GTX Ltd. and 97 GSX Miss

    newskier, please post what you find, I also have been trying to find the same issue with a 97 GSX 800, newwires didn't help, went maticucluosly thro the carbs, and did the carb kits, it made a slight improvement( but not much), next, I'm thinking is a coil, be my next thing to try on mine when I have time. Seems to miss up untill 4000-4400 on mine. New plugs, compression @ 15o each cylinder, been doing alot of reading, had suggestions of the rotary valve seal leaking, another suggestion a crankshaft seal............hope it doesn't take me that far. So to summarize, trying a coil next with new plugs.Keep me posted on your trouble shooting:emoticont

  6. #6
    Joined
    Jul 2005
    From
    Charleston, SC
    Posts
    16

    Default Re: 99 GTX Ltd. and 97 GSX Miss

    K0ke,
    I will let you know what I found. Clipped the wires and found the rave valve was not screwed out per the manual. Probably will not put in this weekend for the following problem that I could use some advice on:

    The 99 GTX has or does have a water leak out of the head pipe that has been dripping on the carbs. When I went to adjust the low speed screws, the mag carb screw froze and one of the twist handles broke off. Can't move it now and I have to pull the carbs to repair.

    The question is, can I get the head pipe gasket replaced (I have the kit with the external foam surround) without pulling that whole unit? Want it done right but still looking for ease. Thanks for any advice.
    Warren

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •