SBT Jetski Engines, Parts & Accessories

Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1
    Joined
    Sep 2005
    From
    Miami
    Posts
    23

    Question 787 Rotax Motor Rebuilt the top end but motor wont start

    I recently (and stupidily) ran my 1800 Challenger without oil. I totally wore out the pistons and it's rings on one of the engines (its a twin). Anyway I bought a piston rebuild kit and installed everything as the shop manual states (btw I have never did this before). After I tighten everything to torque specs and plugged in all the hoses I crank the engine and it wont start!! Very frustrating after working for days on it. The engine turns , the spark plugs have sparks, the fuel is good (since the other engine works) battery is ok. I didnt check the compression becuase I dont have one of those testers ( will buy one ). After trying to crank it for a while I shot starter fluid and that didnt work either. A couple of times it started but immediately died. Not sure what the problem is. BTW when i took the spark plugs off to check them. I noticed the oil was a grayish color. One more so than the other. Any suggestions. I need help on this because I can't afford a sea doo dealer mechanic!!!

  2. #2
    Joined
    Feb 2004
    From
    New Jersey
    Posts
    2,601

    Default Re: 787 Rotax Motor Rebuilt the top end but motor wont start

    do not use starting fluid . if you tore up your pistons with no oil iam sure the crank is not feeling to well . did you check it ? also did you check the rotory valve ? if not check it now . if the plugs are gray and fould it will not start the gray is dirt from the rebuild , you need to confirm the rotory valve is in time and spinning and that you have good compression , if so then put a new set of spark plugs in .
    PRIDE IN SERVICE<br /> <img src="http://www.sbtontheweb.com/images/forposts/4609/1.jpg" alt=" - " />

  3. #3
    Joined
    Nov 2003
    From
    Glendora, CA
    Posts
    6,846

    Default Re: 787 Rotax Motor Rebuilt the top end but motor wont start

    Check your fuel lines to be sure they are not reversed and also make sure you connected the pulse line to the cases and carbureators.
    Bill O'Neal <br>
    WCM
    <a href="http://www.watercraftmagic.com"

  4. #4
    Joined
    Aug 2004
    From
    Olympia, WA
    Posts
    3,629

    Default Re: 787 Rotax Motor Rebuilt the top end but motor wont start

    Make sure you fuel selector is set to ON. A lot of these boats have one selector for each engine.
    Dan Solie -
    04 RXP (the "Instigator")
    94 xp (freestyle mods)
    95 xp (faster than the 94)
    JS550 (the toothpick & the loaner)

    For FREE Seadoo Manuals - Click HERE!!!!

    http://www.tripleateam.com/water/v/U...ery/Dan-Solie/

    **** Please do not PM me. I don't do PM's.... Please post your question on the correct forum so that all can see and learn. Thanks! ****

  5. #5
    Joined
    Sep 2005
    From
    Miami
    Posts
    23

    Default Re: 787 Rotax Motor Rebuilt the top end but motor wont start

    When I checked my pistons and saw that I tore them up I also checked the crankcase by checking if I ran it dry. I opened the plug on the side and it still had oil in there also it turned fine so I assumed the crankcase was fine. The rotary is indeed spinning. The spark plugs are brand new.

  6. #6
    Joined
    Mar 2003
    From
    SBT
    Posts
    21,545

    Default Re: 787 Rotax Motor Rebuilt the top end but motor wont start

    You didn't inspect anything. You needed to break it down and properly inspect every inch if the crank and bearings.
    SBT Tech Support is here to help with your problems.
    We try to answer each question quickly and accurately.
    Please do not use Private Messaging for Tech Support, use the forums.

  7. #7
    Joined
    Sep 2004
    From
    INDIANA
    Posts
    152

    Default Re: 787 Rotax Motor Rebuilt the top end but motor wont start

    In your first post you didnt mention doing anything to the cylinders! did you ? Do a compression test and let us know the numbers.

  8. #8
    Joined
    Sep 2005
    From
    Miami
    Posts
    23

    Default Re: 787 Rotax Motor Rebuilt the top end but motor wont start

    I rehoned the cylinders gave it a nice crosshatch pattern. The ring end gap is .030in ( I know it is a little big but according to seadoo the gap can be up to .039in on a wear limit should work I guess?? ) I will do a compression test shortly will give you my numbers.

  9. #9
    Joined
    Sep 2005
    From
    Miami
    Posts
    23

    Default Re: 787 Rotax Motor Rebuilt the top end but motor wont start

    I checked the compression it was about 150psi on both cylinders. Anything else I can do before I break it down to the crankshaft?

  10. #10
    Joined
    Jul 2004
    From
    chicago
    Posts
    160

    Default Re: 787 Rotax Motor Rebuilt the top end but motor wont start

    Try new plugs....Check all the fule hoses again, and pulse line...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 rider 1100 top end gasket questions
    By 96waveraider1100 in forum Yamaha
    Replies: 0
    Last Post: 08-22-2005, 05:04 PM
  2. '95 SL750 Loss of Top End Power
    By pseudonym in forum Polaris
    Replies: 12
    Last Post: 08-12-2005, 11:20 PM
  3. 97 SL 900 No top end.
    By thetadgt in forum Polaris
    Replies: 4
    Last Post: 08-10-2005, 05:23 PM
  4. New Top End???
    By 99gp1200 in forum Yamaha
    Replies: 3
    Last Post: 10-04-2002, 09:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •