SBT Jetski Engines, Parts & Accessories

Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20
  1. #11
    ADub is offline Showing off on the beach
    Joined
    Aug 2005
    From
    Houston, TX
    Posts
    26

    Default Re: Won't start after carb rebuild

    Got out and properly tested the valve tonight. Sure enough, it has an internal leak.

  2. #12
    ADub is offline Showing off on the beach
    Joined
    Aug 2005
    From
    Houston, TX
    Posts
    26

    Default Re: Won't start after carb rebuild

    Re plumbed the fuel tonight. Carb is pulling fuel, accelerator pump shoots gas, pulse port holds 25 psi vacuum, but I still am not getting fuel into the engine. I'm guessing this means I did not properly rebuild the pump?

    The fuel inlet on the pump will hold 25 psi vacuum, but only pulls 3 psi when cranking. I am guessing this is my problem.
    Last edited by ADub; 09-08-2005 at 08:23 PM.

  3. #13
    Joined
    Jun 2002
    From
    Charlotte NC
    Posts
    1,868

    Default Re: Won't start after carb rebuild

    Put two tablespoons of premix down each carb and then hold the throttle 1/4 open and see if it will start then die. If so then the problem is in the carbs if not the carbs are not the problem.
    Providing mobile JetSki service to the Charlotte / Lake Wylie area.

  4. #14
    ADub is offline Showing off on the beach
    Joined
    Aug 2005
    From
    Houston, TX
    Posts
    26

    Default Re: Won't start after carb rebuild

    Will do. Can anyone tell me how much vacuum I should be pulling on the fuel inlet with the engine cranking? Tech Support?? I do have SBT carb kits in this thing

  5. #15
    Joined
    Mar 2003
    From
    SBT
    Posts
    21,555

    Default Re: Won't start after carb rebuild

    A couple psi is all it's supposed to pull from the tank. Without seeing it I have no idea if you built it correctly - or even if you have the lines connected correctly. What fitting do you have the inlet line attatched to? What did you set pop-off to?
    SBT Tech Support is here to help with your problems.
    We try to answer each question quickly and accurately.
    Please do not use Private Messaging for Tech Support, use the forums.

  6. #16
    Joined
    Jun 2005
    From
    Fox River Illinois
    Posts
    15

    Default Re: Won't start after carb rebuild

    What are the correct locations for the supply and return lines?

    On my 94 640, I believe that the supply line is on the bottom and the return line is on the top? Is this correct?

    I'm having the same problem... it'll run on premix, and sometimes off the tank for a while (maybe 4 or 5 minutes), but then it dies and won't start again...

    I haven't checked the fuel lines or fuel filter yet (one of my next steps)

    I have rebuilt the carb, but I have no way of checking the pop-off pressure.

    -J

  7. #17
    Joined
    Mar 2003
    From
    SBT
    Posts
    21,555

    Default Re: Won't start after carb rebuild

    Start your own thread.
    SBT Tech Support is here to help with your problems.
    We try to answer each question quickly and accurately.
    Please do not use Private Messaging for Tech Support, use the forums.

  8. #18
    ADub is offline Showing off on the beach
    Joined
    Aug 2005
    From
    Houston, TX
    Posts
    26

    Default Re: Won't start after carb rebuild

    Not worried about the right lines in the right place, I have that much confidence. I have been wrenching on on vehicles for 15 years, just never a jet ski........Pop off is set at 20 psi

  9. #19
    Joined
    Jul 2017
    From
    Los Angeles
    Posts
    4

    Default Re: Won't start after carb rebuild

    I blew into the return line but nothing happened except air came back out of the return line.

  10. #20
    Joined
    Apr 2018
    From
    Crown Point
    Posts
    1

    Default Re: Won't start after carb rebuild

    Quote Originally Posted by ADub View Post
    Not worried about the right lines in the right place, I have that much confidence. I have been wrenching on on vehicles for 15 years, just never a jet ski........Pop off is set at 20 psi
    30 - 40 psi


    Sent from my SM-G935T using Tapatalk

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Carb rebuild kit 1998 Polaris SLTH
    By DaBank in forum Polaris
    Replies: 8
    Last Post: 07-03-2006, 09:19 PM
  2. Mikuni Carb Rebuild Question
    By mase in forum Sea-Doo
    Replies: 3
    Last Post: 06-22-2006, 11:02 AM
  3. Carb Rebuild Gone Bad
    By JimZ in forum Sea-Doo
    Replies: 6
    Last Post: 09-13-2004, 03:52 PM
  4. carb rebuild kit?
    By *97GTX* in forum Questions about SBT
    Replies: 2
    Last Post: 06-28-2004, 01:27 PM
  5. ts 1oooL no start after carb rebuild
    By tack in forum Tigershark
    Replies: 11
    Last Post: 07-02-2003, 11:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •