SBT Jetski Engines, Parts & Accessories

Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    Joined
    Aug 2005
    From
    Strong Island New York!!
    Posts
    34

    Default clanking noise!!!!!

    Ok guys im new to the whole pwc thing. i just recieved a 95 slt 750. The engine had been freshly rebuilt this past spring. But i have not used it since i recieved it. My problem is that when i got to turn the motor over theres a claning sound comming from the jet drive. teh previouls owner told me that it was because of salt build up in the housing. But iv also been told that the bearings need to be preplaced an if not ill end up blowing my enigne. AN i have no idea were i can get a bearing rebuuild kit. PLEASE HELP!!!!!

  2. #2
    Joined
    Oct 2004
    From
    Arkansas
    Posts
    173

    Default Re: clanking noise!!!!!

    My best opinion would be to purchase a Clymer manual and go to www.partsland.com for the illustrated parts breakdown. I don't believe there is a kit available. Purchase seperate parts.They are a reliable company and shipping is fast.

    The Clymer manual has pics. Be sure to buy the special tool from them if your model requires it.

    And use Ultra Blue Permatex RTV sealer to seal the pump to the ski.(avail at Wal Mart)

    You will also need new seals between the pump and the ski and new rubber bumpers for the drive shaft and also 2 new seals (P/N 3610040) for the center bearing support($12.00). or purchase the entire unit($95.00).
    Hope this helps.

    Cheers !!

  3. #3
    Joined
    Aug 2005
    From
    Strong Island New York!!
    Posts
    34

    Default Re: clanking noise!!!!!

    Thanks for the info!!! I already have the polaris service manual i just wasnt sure wich parts were needed. but the parts you sugested there still available at a polaris dealer rite? If not do you know of any links you could send me i would greatly appreciate it:emoticont

  4. #4
    Joined
    Nov 2004
    From
    CT
    Posts
    154

    Default Re: clanking noise!!!!!

    It might be normal these thing's sound like a box of rocks out of the water with no load. But you should check the bearings in the pump housing. Remove Item # 26 to remove the pump from the hull.Then check for bearing drag or tightness.
    http://www.partsland.com/index.cgi?N...750-PROPULSION

  5. #5
    Joined
    Aug 2005
    From
    Strong Island New York!!
    Posts
    34

    Default Re: clanking noise!!!!!

    yea thats what im gonna do, cuz this thing sound like its all loose inside when i turn it over. I rather take it apart no an found out i need bearings, then risk it an blow a motor with a half hour of run time on it

  6. #6
    Joined
    Apr 2004
    From
    HUMBLE /ATASCOCITA TX
    Posts
    763

    Default Re: clanking noise!!!!!

    Is the clanking noise while running on a trailer or in the water?
    WATERCRAFT SERVICES. PROVIDING THE RESIDENTS OF HOUSTON AND SURROUNDING AREAS WITH QUALITY WORK ON THEIR PWC AT A FAIR PRICE.

  7. #7
    Joined
    Aug 2005
    From
    Strong Island New York!!
    Posts
    34

    Default Re: clanking noise!!!!!

    on the trailer. You gotta hear it, its loud an it sounds liek the impeller is jumpin around inside. It literally sounds like its gonna fall apart.

  8. #8
    Joined
    Jul 2005
    From
    Pensacola FL
    Posts
    50

    Default Re: clanking noise!!!!!

    every polaris i have seen makes that noise when its on the trailer. the impeller is bouncing around inside the housing and that *ping* you hear is the blades hitting the housing cuz there no water to act as a cushion.

  9. #9
    Joined
    Jan 2002
    From
    Jefferson City, MO
    Posts
    680

    Default Re: clanking noise!!!!!

    They are noisy, but its worth it to take a closer look, I've seen them come off the shaft before.

    I do have a totally complete pump unit off a running 95 SLT for sale if it matters. I think I posted it in the classifieds here recently.

  10. #10
    Joined
    Aug 2005
    From
    Strong Island New York!!
    Posts
    34

    Default Re: clanking noise!!!!!

    i think im gonna pull the jet pump off any way an check the bearings just to be safe. I really dont wanna risk blowing an engine with a half hour on it. But yes my drive is making that ping noise when i start it on the trailer. I tried spraying WD40 into the pump an starting it an its still clanking. Maybe ill try to inject the pump with water.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1997 GTX making loud noise
    By traskb1 in forum Sea-Doo
    Replies: 3
    Last Post: 06-02-2006, 12:34 PM
  2. 1991 WR500 Clicking/pinging noise?
    By drewchips in forum Yamaha
    Replies: 4
    Last Post: 12-13-2005, 12:47 PM
  3. Replies: 14
    Last Post: 10-19-2005, 01:18 AM
  4. 01 Seadoo XP Engine Noise
    By gifer in forum Sea-Doo
    Replies: 11
    Last Post: 08-14-2004, 12:08 PM
  5. 94 XP - Strange noise
    By Mike McCaslin in forum Sea-Doo
    Replies: 3
    Last Post: 08-08-2004, 06:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •