SBT Jetski Engines, Parts & Accessories

Results 1 to 5 of 5
  1. #1
    Joined
    Feb 2006
    From
    Tampa, FL
    Posts
    8

    Default bad rattling when idling

    When i run the waverunner at idle it runs fine for a little when but sometimes i hear a loud rattling sound start to develop but when i hit the throttle a little bit it stops and after another while it does it again. It only does it when idling. Can somebody tell me why this happens and what is going on? It runs fine except that rattling noise. Is is something serious that i should worry about or just ignore since the waverunner runs fine? All help would be appreciated thans!

  2. #2
    Joined
    Nov 2003
    From
    Glendora, CA
    Posts
    6,846

    Default Re: bad rattling when idling

    You are hearing the impellor splines rattling on the driveshaft splines. It is completly normal and harmless. Do not worry about it.

    BTW, a Sea Doo is not a waverunner, nor is it a jetski. A Waverunner is made by Yamaha, a jetski is made by Kawasaki. A Sea Doo is reffered to as a Sea Doo..
    Bill O'Neal <br>
    WCM
    <a href="http://www.watercraftmagic.com"

  3. #3
    Joined
    Aug 2004
    From
    Olympia, WA
    Posts
    3,629

    Default Re: bad rattling when idling

    It also couldn't hurt if you grease your PTO too. I have noticed that my 94XP makes a little louder of a noise when she wants grease...
    Dan Solie -
    04 RXP (the "Instigator")
    94 xp (freestyle mods)
    95 xp (faster than the 94)
    JS550 (the toothpick & the loaner)

    For FREE Seadoo Manuals - Click HERE!!!!

    http://www.tripleateam.com/water/v/U...ery/Dan-Solie/

    **** Please do not PM me. I don't do PM's.... Please post your question on the correct forum so that all can see and learn. Thanks! ****

  4. #4
    Joined
    Feb 2006
    From
    Tampa, FL
    Posts
    8

    Default Re: bad rattling when idling

    whats a PTO?

  5. #5
    Joined
    Mar 2003
    From
    SBT
    Posts
    21,545

    Default Re: bad rattling when idling

    Power Take Off coupler - the part the driveshaft connects to at the engine.


    The SBT Forums are for SBT Product Support ONLY. For all general PWC support/discussion, please post on www.pwctoday.com.


    Thank you - SBT Mgt.
    SBT Tech Support is here to help with your problems.
    We try to answer each question quickly and accurately.
    Please do not use Private Messaging for Tech Support, use the forums.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. PLEASE HELP!! bad experience with NEW sbt 657
    By jeburbank in forum The SBT Experience
    Replies: 11
    Last Post: 06-28-2007, 02:33 PM
  2. NEW SBT 1100ZXI Crank with bad runout!!!
    By Mochanic in forum Kawasaki
    Replies: 4
    Last Post: 07-11-2005, 04:49 PM
  3. Why only 1 cylinder bad?
    By wmsky in forum Yamaha
    Replies: 1
    Last Post: 07-10-2005, 09:37 PM
  4. Possible bad crank....
    By James Miller in forum Polaris
    Replies: 4
    Last Post: 10-11-2004, 05:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •