SBT Jetski Engines, Parts & Accessories

Results 1 to 2 of 2
  1. #1
    Joined
    May 2005
    From
    Virginia
    Posts
    3

    Default 2002 GTX 4TEC still leaking coolant!! HELP!!

    After de-winterizing, took my first ride yesterday. I'm still losing coolant, even after re-inspecting all hoses, clamps, etc and pressure checking system. Did notice a very small amount of coolant coming out of weep hole at base of water pump. Had to use small inspection mirror even to notice that. Anyone experienced a rotary valve failure? Or is this normal? Should I be looking for any other problem areas?

  2. #2
    Joined
    Mar 2003
    From
    SBT
    Posts
    21,545

    Default Re: 2002 GTX 4TEC still leaking coolant!! HELP!!

    The SBT Forums are for SBT Product Support ONLY. For all general PWC support/discussion, please post on www.pwctoday.com.


    Thank you - SBT Mgt.
    SBT Tech Support is here to help with your problems.
    We try to answer each question quickly and accurately.
    Please do not use Private Messaging for Tech Support, use the forums.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GTX 4TEC coolant in engine oil problem
    By mazzerman in forum Sea-Doo
    Replies: 4
    Last Post: 04-28-2007, 07:30 AM
  2. 2002 GTX 4TEC Venting Battery
    By JoelF in forum Sea-Doo
    Replies: 2
    Last Post: 04-18-2007, 11:49 PM
  3. 2002 GTX 4TEC Crankshaft
    By mazzerman in forum Sea-Doo
    Replies: 2
    Last Post: 06-01-2006, 12:13 PM
  4. 2002 GTX 4TEC Pump Oil????
    By JoelF in forum Sea-Doo
    Replies: 2
    Last Post: 10-30-2005, 09:08 PM
  5. 2002 GTX 4tec Coolant leak!!
    By pashton394 in forum Sea-Doo
    Replies: 1
    Last Post: 05-25-2005, 09:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •