SBT Jetski Engines, Parts & Accessories

Results 1 to 2 of 2
  1. #1
    Joined
    Jun 2006
    Posts
    1

    Default GTX 4-tec oil warning light and buzzer

    I recently purchased a 2004 GTX 4-tec supercharged jet ski with around 40 hours. I took it out on the river late last fall and it ran great for the first 10 mins. As it warmed up, the oil light and warning buzzer started to sound when I would let it idle. I took it to the shop over the winter, and the mechanic couldnt find any codes or problems, he checked the oil level and and oil sensor, and said they were fine. He changed the oil, and still no problems. I took it out again early spring, and ran it for about 1.5 hours, and no light or buzzer. I took it out again yesterday, and the light came on approximately 3 times. It seems to only come on after I have ran it on plane for a little bit, and then decerlate and it I let it idle for about 10 seconds. I can stop it, then restart it, and it will run fine, but once i decelerate, it will start sounding again. Has anyone had these similar problems?? Any suggestions?

  2. #2
    Joined
    Mar 2003
    From
    SBT
    Posts
    21,545

    Default Re: GTX 4-tec oil warning light and buzzer

    The SBT Forums are for SBT Product Support ONLY. For all general PWC support/discussion, please post on www.pwctoday.com.


    Thank you - SBT Mgt.
    SBT Tech Support is here to help with your problems.
    We try to answer each question quickly and accurately.
    Please do not use Private Messaging for Tech Support, use the forums.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •