SBT Jetski Engines, Parts & Accessories

Results 1 to 5 of 5

Thread: SBT motor

  1. #1
    Joined
    Jul 2005
    From
    SOUTH CAROLINA
    Posts
    4

    Default SBT motor

    I replaced my motor 3 years ago with a sbt 587 motor for 96 sea doo sp,since i have been scoring rotary valve covers every time i go out on the lake i took the motor apart to look at the crank and pistons,they are fine.i posted this awhile ago about scoring my rotary covers badly,i have bought 4 covers from sbt and thats why i took the motor apart to see if i had metal or anything else in the motor,i found nothing,the responses i got in the past was that my sp was probably sucking up water in the carb ruining rotary covers but would that effect the rest of the motor also? the oil pump is working fine as i have checked it and it was replaced when i installed the sbt motor.i have rebuilt jet pump and replaced carbon ring and all seals to eliminate any water leaks and at this point the last time i took it out there was a little water in the hull but i do jump waves and such. i"m going to purchase another cover and valve since the outside of the valve is scored also,:emotredf it looks like a record.is there anything else you know of that could cause this problem.i did check rotary valve cover clearance and it was okay.compression 150 and 147,and do you sell the snap rings for the pistons so i can put new ones in.

  2. #2
    Joined
    Mar 2003
    From
    SBT
    Posts
    21,545

    Default Re: SBT motor

    You can ask sales if we have some extra c-clips for your pistons laying around. You may have a water leak somewhere spraying a mist in your hull or something - debris (like water) is the only thing that's going to be doing that to you.
    SBT Tech Support is here to help with your problems.
    We try to answer each question quickly and accurately.
    Please do not use Private Messaging for Tech Support, use the forums.

  3. #3
    Joined
    Jul 2005
    From
    SOUTH CAROLINA
    Posts
    4

    Default Re: SBT motor

    Quote Originally Posted by Technical Support
    You can ask sales if we have some extra c-clips for your pistons laying around. You may have a water leak somewhere spraying a mist in your hull or something - debris (like water) is the only thing that's going to be doing that to you.
    thanks for the reply,i will continue to search for water leaks,i did fill the hull up with water to check for leaks and found none,are those piston circlips just regular ones i could get at a hardware store?

  4. #4
    Joined
    Mar 2003
    From
    SBT
    Posts
    21,545

    Default Re: SBT motor

    No they are specific to the pistons.

    More likely than a hull leak is a water line or craked part leaking.
    SBT Tech Support is here to help with your problems.
    We try to answer each question quickly and accurately.
    Please do not use Private Messaging for Tech Support, use the forums.

  5. #5
    Joined
    Jun 2001
    From
    Largo,Florida
    Posts
    152

    Default Re: SBT motor

    Check your seat gasket.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Preseason check list!!
    By jcar25 in forum Sea-Doo
    Replies: 4
    Last Post: 08-22-2021, 05:49 PM
  2. Few Issues with SBT motor and SBT starter
    By cdmx in forum Kawasaki
    Replies: 1
    Last Post: 03-26-2008, 08:48 AM
  3. new sbt motor premix or oil inject
    By speedfreak800r in forum Sea-Doo
    Replies: 2
    Last Post: 04-19-2006, 04:22 AM
  4. 1994 Polaris SLT SBT Motor Problems
    By sspracing in forum Polaris
    Replies: 21
    Last Post: 08-24-2005, 08:03 PM
  5. New motor from SBT
    By fallcityjames in forum Sea-Doo
    Replies: 4
    Last Post: 08-20-2005, 02:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •