SBT Jetski Engines, Parts & Accessories

Results 1 to 5 of 5
  1. #1
    Joined
    Oct 2004
    From
    miami
    Posts
    10

    Default 2003 SR230, MR1 Engine Power loss and check engine light flashing

    My check engine light is flashing after being out about 30 minutes and cannot get the engine above 8000 RPM. Definately weaker than the other engine.

    Ideas, or ideas to check?

  2. #2
    Joined
    May 2007
    From
    New Brunswick,NJ
    Posts
    3

    Default Re: 2003 SR230, MR1 Engine Power loss and check engine light flashing

    I may be having a similiar issue on my 06' FX HO. First ride of the season was only about an hour long (just wanted to test it out). It ran perfect.

    2 days later I drop it in the lake and now it won't go much past 8000 RPMs (roughly 45 mph). The check engine light came on for a second and I turned it off then back on and it stayed off for the rest of the day. It runs perfect besides the fact it won't go higher than 8000-8500 RPM.

    My first thoughts were the old gas in the tank from last year even though I added stabalizer, but once it was down to two bars I filled it up with fresh gas, still same results. It still could be that the computer needs time to adjust to the better gas.

    I've been reading some posts and I mostly see the problem being an oil soaked air filter or bad spark plugs. I find it hard to believe that a day before it was running full speed and now its not and it being because of those two things. I haven't had a chance to open it up and check the engine, but I'll let you know what I find.

  3. #3
    Joined
    Oct 2004
    From
    miami
    Posts
    10

    Default Re: 2003 SR230, MR1 Engine Power loss and check engine light flashing

    I have come to the same conclusion, I bought new plugs and will be changing them and checking the air cleaner. I also have a FX140 HO, same engine, and I had this happen, and that was the fix. The shop filled the oil to the top and it got to the filter. This is why I change my own oil now and fill it not to the top.

  4. #4
    Joined
    May 2007
    From
    New Brunswick,NJ
    Posts
    3

    Default Re: 2003 SR230, MR1 Engine Power loss and check engine light flashing

    I checked my air filter and it was nice and dry with no oil. I looked at one of the plugs and it looked normal however it still could be fouled. I'm going to replace them all and put in some fresh gas in to see if that works.

  5. #5
    Joined
    May 2007
    From
    New Brunswick,NJ
    Posts
    3

    Default Re: 2003 SR230, MR1 Engine Power loss and check engine light flashing

    Still haven't had a chance to test out the fix. I did get a chance to replace my plugs yesterday. All of them but one was oil soaked (not too heavy, but enough to foul them I suppose).

    I checked the oil level cold and the level was about a half inch above the F. I think the oil level was too high so I removed about a quart to get the level to fall in between the L and F. I read that cold the level should be low and once at operating temperature it should be between the L and F marks.

    Today I hope to take it out and see how it runs and will also keep a close watch on the oil level.

    Were you able to fix your boat?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Carb tuning question
    By tomsl750 in forum Polaris
    Replies: 2
    Last Post: 08-14-2002, 10:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •