SBT Jetski Engines, Parts & Accessories

Results 1 to 2 of 2
  1. #1
    Joined
    Jul 2007
    From
    NJ
    Posts
    1

    Default Rope around shaft, now starter doesn't turn over?

    Hopefully someone has had this happen before and can save me some time troubleshooting... My 1999 GP1200 sucked a dockline into the intake grate, and the rope wound around the shaft (but didn't get into the impeller). My wife was on it, and tried once or twice to start, not realizing the rope was there. We towed it about 200 feet to the davit, and lifted it out of the water. After removing the intake grate and unwinding the rope, we tried starting it. The gauges show signs of life, but no sound from the starter - no clicking or anything. I charged and tested the battery, and even put a booster pack on it, but same results. I'm assuming that when the starter button was held down while the shaft was locked up, that we smoked the starter or something similar. Is there a fuse or anything easy to check? I know that the main fuse in the engine compartment is still good. I just don't want to start replacing items to figure out the problem. One note: This problem never happened before, and we've never had trouble starting. The battery contacts are clean and clear of corrosion.

    Any help GREATLY APPRECIATED!!!
    Thanks,
    Brad

  2. #2
    Joined
    Sep 2007
    From
    Georgia
    Posts
    2

    Default Re: Rope around shaft, now starter doesn't turn over?

    Same thing happened to me a cpl of years ago. The starter has a relay located in the "Black Box" located on back wall of ski. Replace the starter relay assembly. Should be your issue. Hope that helps.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Yamaha 800 Starting Help Needed.
    By Ericka-SBT in forum Yamaha
    Replies: 4
    Last Post: 05-16-2017, 10:17 AM
  2. help! got rope caught around shaft
    By pwint in forum Sea-Doo
    Replies: 3
    Last Post: 10-25-2007, 12:05 AM
  3. starter has hard time to turn the motor
    By vladimir in forum Yamaha
    Replies: 0
    Last Post: 07-18-2007, 02:59 PM
  4. starter won't turn over engine
    By bethron1 in forum Tigershark
    Replies: 1
    Last Post: 04-17-2006, 09:39 PM
  5. Starter wont turn motor?
    By Stevens4119 in forum Sea-Doo
    Replies: 1
    Last Post: 11-20-2004, 03:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •