Hopefully someone has had this happen before and can save me some time troubleshooting... My 1999 GP1200 sucked a dockline into the intake grate, and the rope wound around the shaft (but didn't get into the impeller). My wife was on it, and tried once or twice to start, not realizing the rope was there. We towed it about 200 feet to the davit, and lifted it out of the water. After removing the intake grate and unwinding the rope, we tried starting it. The gauges show signs of life, but no sound from the starter - no clicking or anything. I charged and tested the battery, and even put a booster pack on it, but same results. I'm assuming that when the starter button was held down while the shaft was locked up, that we smoked the starter or something similar. Is there a fuse or anything easy to check? I know that the main fuse in the engine compartment is still good. I just don't want to start replacing items to figure out the problem. One note: This problem never happened before, and we've never had trouble starting. The battery contacts are clean and clear of corrosion.

Any help GREATLY APPRECIATED!!!
Thanks,
Brad