SBT Jetski Engines, Parts & Accessories

Results 1 to 8 of 8
  1. #1
    Joined
    Feb 2004
    From
    New Jersey
    Posts
    2,601

    Red face problems for the first time

    Ask anyone i have and will always say SBT is great , i have however run into a problem with a 4 stroke that got 4 hrs and a snaped timming chain . then some problems with getting this fixed in a timly matter . i dont know what has changed but comon guys and gals over there get on the ball on this , not just the engine but the guys shipping money also its been long enough as of yesterday he still has not been refunded for the shipping . the guy has been very cool with me but this is making me look bad as i pushed for him to go with a reman engine from SBT .
    PRIDE IN SERVICE<br /> <img src="http://www.sbtontheweb.com/images/forposts/4609/1.jpg" alt=" - " />

  2. #2

    Default Re: problems for the first time

    Chris,
    I need more information from you. Please call me at the office and I can get this cleared up.
    Ericka
    Ericka Buczkowski
    SBT

  3. #3
    Joined
    Feb 2004
    From
    New Jersey
    Posts
    2,601

    Thumbs up Re: problems for the first time

    Thank You problem solved your the BEST :-)
    PRIDE IN SERVICE<br /> <img src="http://www.sbtontheweb.com/images/forposts/4609/1.jpg" alt=" - " />

  4. #4
    Joined
    Feb 2004
    From
    New Jersey
    Posts
    2,601

    Default Re: problems for the first time

    well the ski is comming back , SBT does know that the sec engine failed within a few hrs of running , the poor guy has been stuck at a shop who says they can not get the codes off the mpem since the guage is bad , they wanted the guy to buy a new guage just to read codes , iam taking over this job again , i was told today that the customer was told by SBT that he has to pay shipping back again ? and that something in the ski might be blowing this engine . SBT told him the first time his new engine blew within a few hrs that a bad starter might blow it , he bought a bran new starter . now they tell him it could be a bad battery ? come on SBT stop with the crap and stepup here this guy has spent a ton of money .. the first engine was a snaped timming chain with about 4 hrs run time . this time its low compression and shavings in the oil filter with about the same amount of hrs .

    I am doing this job free of labor charges for the guy SBT needs to stepup and take care of there bad engines he has got . i will report more when the ski gets here .
    PRIDE IN SERVICE<br /> <img src="http://www.sbtontheweb.com/images/forposts/4609/1.jpg" alt=" - " />

  5. #5
    Joined
    Mar 2003
    From
    SBT
    Posts
    21,545

    Default Re: problems for the first time

    What year and model is this machine? has the customer replaced the gauge to see if any codes are active? If the battery had low power and the engine turned over slow it could cause the timing chain to fail if he continued cranking. If the starter was failing and the engine was turning over slow it could also cause the engine to snap the timing chain if continually cranked. Did the customer rebuild the oil pumps when he installed the new engine? There are many things to look at here before anyone is to point a finger at anyone. We will be more than happy to help with the issue if you can provide us with more info, feel free to call in and speak to Tom in the tech department.
    SBT Tech Support is here to help with your problems.
    We try to answer each question quickly and accurately.
    Please do not use Private Messaging for Tech Support, use the forums.

  6. #6
    Joined
    Feb 2004
    From
    New Jersey
    Posts
    2,601

    Default Re: problems for the first time

    I can point the finger , i know the customer and the hrs on the ski since it both engines blew , it is not the ski . it did have a new battery and new starter just to cover bases this time , i thought it was a joke when the first engine went and tech told the guy that the starter was prob the couse . i have a few dealers as friends and didnt say why but asked all of them if they ever had a weak starter or battery blow a engine they all laughed . its known that seadoo had problems with the timing chain , and my customer had to pay shipping back you you guys the first time and i stuck up for SBT 100% now it will be time for SBT to step up and cover some stuff for this guy . i just dont like what he has told me sofar about sbt needing codes and him needing to pay for shipping again and SBT telling him a weak battery could be his problem , SBT seems to have changed a lot with people who work there i dont know why but its not the SBT i knew that helped the customer instead of putting the customer deep in debit becouse there engine failed and they keep blaming the ski or customer . iam not naming people right now and soon as the ski is here i will post more about it and what SBT does for him . anyone who knows me ,knows i have only dealt with 1 4tec from sbt figureout whos ski it is . this guy has about 8 hrs in 2 seasons on 2 SBT engines and has spent a ton of money and he lives about 4hrs from me he has spent more time on the road then the water just not right. if he was taking care of like he should have been this post would never have been started . sorry to the people i know and like and have dealt with over the years at SBT you guys and gals still rock .
    PRIDE IN SERVICE<br /> <img src="http://www.sbtontheweb.com/images/forposts/4609/1.jpg" alt=" - " />

  7. #7
    Joined
    Feb 2004
    From
    New Jersey
    Posts
    2,601

    Default Re: problems for the first time

    Heres a update on this ski , i have it at the shop now , PSI is 150 150 125 , the info guage was bad i swapped it out with a test gauge , no codes the dealer he took it to last season said they found medal shavings in the oil , i did find a few on the filter { 5 or 6 small shiny spots} nothing to say OMG , i changed the oil and have ran about 2 tanks of fuel though the ski sofar . mph say 55 ofcourse mph gauges dont tell much , the RPMs are about 7200

    right now the only concern is the PSI its not burning oil or using antifreeze so i would say a valve .

    SO i will say its not as bad as thought and again the DEALER lied about a few things to the owner and had him more upset then he should have been , BUT SBT telling him his starter could have blown his ski didnt help LOL so i will be calling SBT soon :-)
    PRIDE IN SERVICE<br /> <img src="http://www.sbtontheweb.com/images/forposts/4609/1.jpg" alt=" - " />

  8. #8
    Joined
    Feb 2004
    From
    New Jersey
    Posts
    2,601

    Default Re: problems for the first time

    update , SBT has worked out with the customer a agreement { found a bad rocker } sec engine , the first was a broke timing chain . lets hope the 3rd is the charm LOL I dont want to do anymore free R&Rs . did you ever feel a ski was jinxed ha . Well i will post a update on the 3rd engine when we get some hrs run on it i was told it will be here this week coming.
    PRIDE IN SERVICE<br /> <img src="http://www.sbtontheweb.com/images/forposts/4609/1.jpg" alt=" - " />

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. please help first time 94sp problems
    By slo94sp in forum Sea-Doo
    Replies: 1
    Last Post: 03-09-2006, 07:48 PM
  2. Boat Problems
    By 96challenger in forum Sea-Doo
    Replies: 3
    Last Post: 02-25-2006, 11:06 PM
  3. 96 xp 3 Long Questions build up/ problems
    By zackz28 in forum Sea-Doo
    Replies: 11
    Last Post: 06-23-2005, 02:14 PM
  4. Problems With Kawasaki 1100 STX DI
    By paladin7485 in forum Kawasaki
    Replies: 7
    Last Post: 05-18-2005, 04:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •