SBT Jetski Engines, Parts & Accessories

Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Joined
    Jun 2008
    From
    canada
    Posts
    7

    Default weak 1200 with turbo

    when I first get on the throttle it has lots of power, but after I plane for a min and let off the throttle and go to give it more throttle I dont have the power that I should, almost seems like the turbo is not boosting, I am a skilled tech and I have had it at the dealer and they could not fix it. I have checked everything elec. and all the wires for any opens or shorts, all the sensores, and its not throwing any codes. I have checked timming, fuel pressure and its good. Let me know if anyone has come across this engine has perfect compression and runs and revs off sore perfect.

  2. #2
    Joined
    Sep 2007
    From
    London, ON, Canada
    Posts
    74

    Default Re: weak 1200 with turbo

    Maybe the rider is too heavy. Try losing some weight. ;)
    1997 Speedster (twin 720s)
    London, Ontario, Canada

  3. #3
    Joined
    Jun 2008
    From
    canada
    Posts
    7

    Default Re: weak 1200 with turbo

    are you sayin that I am fat? What are you getting at? maybe we should take this one outside?

  4. #4
    Joined
    Sep 2007
    From
    London, ON, Canada
    Posts
    74

    Default Re: weak 1200 with turbo

    I figured the techs on this board could help you with your problem....I am surprised that they haven't commented yet, or suggested to try anything.
    1997 Speedster (twin 720s)
    London, Ontario, Canada

  5. #5
    Joined
    Mar 2003
    From
    SBT
    Posts
    21,545

    Default Re: weak 1200 with turbo

    Sounds like your waste gate is sticking open, If you send me your fax number I can give you info on checking the components. It could be the waste gate solinode or the actuator. tom@sbtontheweb.com Pay no attention to Craigs post as you can see in his picture his engine is still in pieces on his work bench and he's not there. We try to keep up with every ones questions, But this is the busy season. sorry. Tom.
    Last edited by Technical Support; 07-03-2008 at 11:30 AM.
    SBT Tech Support is here to help with your problems.
    We try to answer each question quickly and accurately.
    Please do not use Private Messaging for Tech Support, use the forums.

  6. #6
    Joined
    Sep 2007
    From
    London, ON, Canada
    Posts
    74

    Default Re: weak 1200 with turbo

    Tom, I emailed you.

    Alex, I gave Tom KL's fax number.

    Also Alex..didn't Leo from Oxford say something like this also????
    1997 Speedster (twin 720s)
    London, Ontario, Canada

  7. #7
    Joined
    Jun 2008
    From
    canada
    Posts
    7

    Default Re: weak 1200 with turbo

    leo did say somthing about this, this weekend im taking it to the lake and going to focus on the waste gate and waste gate solenoid, control circuit.

  8. #8
    Joined
    Mar 2003
    From
    SBT
    Posts
    21,545

    Cool Re: weak 1200 with turbo

    Guys, Info is on its way. Good luck, tell us what you find.
    SBT Tech Support is here to help with your problems.
    We try to answer each question quickly and accurately.
    Please do not use Private Messaging for Tech Support, use the forums.

  9. #9
    Joined
    Jun 2008
    From
    canada
    Posts
    7

    Default Re: weak 1200 with turbo

    thanks for now

  10. #10
    Joined
    Jun 2008
    From
    canada
    Posts
    7

    Default Re: weak 1200 with turbo

    I switch out the turbo, map senores, tps, ECT, knock, IAC, air intake temp, mst, sensores all from another honda auquatrax that is running good, and It runs good when I first get on it and then looses power again, and the turbo lag is alot long then the other machien, but if I shut it off on the lake and wait 2 min and fire it up again it goes good again for a longer period of time, then eventually goes good again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 XL 1200 or 97 Sedoo XP?
    By bconwayls1 in forum Yamaha
    Replies: 1
    Last Post: 05-01-2006, 11:50 PM
  2. Weak spark
    By yngvemb in forum Kawasaki
    Replies: 1
    Last Post: 02-28-2006, 11:02 PM
  3. 1200 non-pv vs. 1200 pv
    By my2001s2000 in forum Yamaha
    Replies: 14
    Last Post: 07-11-2004, 01:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •