SBT Jetski Engines, Parts & Accessories

Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Joined
    Mar 2004
    Posts
    5

    Post

    What would cause the back piston to blow apart?
    It is a 580 white engine the year is 95. My friend was riding and it made a load pop then started losing power. Got half way back to the dock and then it stopped. The front piston looks good except for the extra metal in it from the back piston. He is going to order a rebluid engine but is there another problem we should look for before installing the new one? any help would be nice. thanks jkool

  2. #2
    Joined
    Aug 2002
    From
    Waterville, Washington
    Posts
    1,390

    Post

    oil pump or premix?

    Did it ingest water?

    How are the carbs, have they been rebuilt and cleaned since he has had it?

  3. #3
    Joined
    Mar 2004
    Posts
    5

    Post

    oil pump, Don't think it had water in it but I didn't flush all the time for him he did once in awhile but it run for about 4 hours that day it died. He didn't redo the carbs but the guy before him did. It was getting oil because the tank was half full and we filled the day. But that doesn't mean the back was getting the oil. He did get alot of weeds in the prop so I thought he fried the crank.

  4. #4
    Joined
    Aug 2002
    From
    Waterville, Washington
    Posts
    1,390

    Post

    seperate the drive shaft from the engine........see if the driveshaft spins with ease disconnected from the engine. How much metal we talking? I have never seen a piston just blow apart, they usually just lock up. Does the rear piston move, could of snapped the rod.........ya really need to tear it down and inspect the lower half also.

  5. #5
    Joined
    Mar 2004
    Posts
    5

    Post

    the shaft spins fine the engine is out and broken down in the lower half the back rod is locked up the front looks great. the bottom half of the piston is gone makes a good ash tray though. I thought the bottom froze and cocked the piston a little and it hit the bottom case but it sounds odd though.Its all apart and ready for swap but I was wondering if its because of oil maybe we should block it and go with pre-mix but I think the oil pump is fairly new 2 or 3 years old. Who knows what the other guy really did to the ski he sent it to the dealer all the time.

  6. #6
    Joined
    Aug 2002
    From
    Waterville, Washington
    Posts
    1,390

    Post

    In my honest opinion......if you don't know what he did to it, block the pump, rebuild the carbs and make sure there is no blockage in any of your fuel or water lines.. If the driveshaft spins on the pump, it's not the pump.

  7. #7
    Joined
    Aug 2002
    From
    Waterville, Washington
    Posts
    1,390

    Post

    One last question, is that a single or dual carb, and how many turns out are they if it's dual(the low speed and high speed circuits)?

  8. #8
    Joined
    Mar 2004
    Posts
    5

    Post

    Its a dual carb but to be honest I have no idea how many turns out it is it ran and if it runs we don't play with them at all untill we have to rebuild the engine btu we are use to kaw 550 and 440 so they are pretty basic to play with. We have had them since 76 the one 440 is and 78 and 86 550 they are just more fun but the sit down are good for relaxing to use. I have to look into rebluiding the carbs and blocking the oil maybe it will be easier and safer. But the ski ran great all summer just fowled the plugs if the kids started it. A least my gp800 runs good.

  9. #9
    Joined
    Aug 2002
    From
    Waterville, Washington
    Posts
    1,390

    Post

    95......what moedel sea_doo?

  10. #10
    Joined
    Aug 2002
    From
    Waterville, Washington
    Posts
    1,390

    Post

    How long did ir run before it took a crap, and did was this just today? Did it run ok in the past?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Blown burnt #2 Piston GP1200R
    By BobFro in forum Yamaha
    Replies: 0
    Last Post: 08-28-2007, 06:05 PM
  2. Blown Piston
    By Gary Anacker in forum Sea-Doo
    Replies: 0
    Last Post: 08-27-2007, 11:49 AM
  3. 98 1100 zxi with blown #1 Piston
    By cminarczik in forum Kawasaki
    Replies: 1
    Last Post: 05-20-2007, 08:26 PM
  4. 1992 sl650 blown mag piston and rod
    By vtec_guy in forum Polaris
    Replies: 1
    Last Post: 07-03-2003, 01:53 AM
  5. Pulling pistons / breaking down engine
    By Sirhc7897 in forum Polaris
    Replies: 18
    Last Post: 06-05-2003, 06:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •