SBT Jetski Engines, Parts & Accessories

Results 1 to 9 of 9
  1. #1
    Joined
    Jul 2017
    From
    Texas
    Posts
    6

    Default 2003 Seadoo GTI LE Problems

    Hello,
    Thanks in advance for any help. On to the issue. Bought 2 theft recovery 2003 GTI's. Put a top end on one and it runs perfect. The second GTI new top end .5 mm over, new sbt crank and rotary plate. Basically Its pretty much a new motor. The problem- It runs great on the hose, but refuses to run in the water. Everything I read indicated my rotary clearance was out of spec. Checked it, was out of spec. replaced rotary valve cover with a SBT one. Assumed I was good, went to the lake. Same symptoms will not crank in water. If I pull trailer out of water, crank and tried to slowly go back in water, it dies. So frustrating. Pulled my carb and intake rechecked rotary valve clearance w/o gasket with bend feeler gauge method. It was still out of spec. Reading was .459 mm. So clearance in range is .25 to .35 mm. Is it that strict on the specs and not run at .109 mm out of range? SBT machines the rotary plate cover back to factory spec, Does anyone one know the factory specs on the plate cover for me to check? I looked and double looked in shop manual couldn't find. Sbt tech told me the measurement on the case side is .136 in. on the rotary case lip to plate surface. I haven't checked that yet. Something is putting me out of range. I have done all the standard stuff forum members ask for. Clip plug wires, new plugs gapped to spec. gone through carb 3 times with rebuild kit. pop off in spec, new top end, new sbt crank, all new gaskets, seals. 145 psi's on both pistons. New rotary shaft/gear bought as a kit. new rotary plate, new rotary cover from sbt. Went through all gas hoses and fuel valve selector. Think that's about it. Am I missing something? something else cause my problems?If I can get the measurements on the rotary cover to check it might help. I hope I don't have to disassemble this engine to have the case side machined. I was told it doesn't wear as much as the rotary cover cause of different metal composition.

    Any help would be awesome.
    CTE
    Last edited by Cte; 07-16-2017 at 01:32 PM.

  2. #2
    Joined
    Jul 2017
    From
    Texas
    Posts
    6

    Default Re: 2003 Seadoo GTI LE Problems

    I forgot to mention it has the 720 engine.

  3. #3
    Joined
    Jun 2016
    From
    Clearwater, Florida
    Posts
    278

    Default Re: 2003 Seadoo GTI LE Problems

    Check exhaust hoses for blockage.

  4. #4
    Joined
    Aug 2016
    From
    connecticut
    Posts
    7

    Default Re: 2003 Seadoo GTI LE Problems

    Make sure it's running on both cylinders...It sounds like your getting faked out with it running on the trailer....In the water, everything has to be perfect once the pump starts working and pushing water..

  5. #5
    Joined
    Jul 2017
    From
    Texas
    Posts
    6

    Default Re: 2003 Seadoo GTI LE Problems

    So back at it again to fix unresolved problem. Yes running on 2cylinders. No exhaust blockage. Anyone else ran into this? Runs fine on trailer, no start or run in water. I even tried to back trailer up in water with Sea-Doo pre cranked. When it hits water it bogs and dies no mater what amount of throttle.

  6. #6
    Joined
    Jun 2016
    From
    Clearwater, Florida
    Posts
    278

    Default Re: 2003 Seadoo GTI LE Problems

    If all of your info from earlier posts is still the same I believe you still have a clearance problem in the rotary valve area.
    From flange on case to case surface is supposed to be 0.136"
    Rotary valve cover face is supposed to be 0.100" depth.
    0.136" - 0.100" = 0.036"
    Rotary valve is 0.024" thick.
    This leaves 0.012" of clearance.
    Check to see if all of this falls in line.

  7. #7
    Joined
    Jul 2017
    From
    Texas
    Posts
    6

    Default Re: 2003 Seadoo GTI LE Problems

    Well do, I'll check this. The rotary valve and rotary valve cover I got from sbt. I will measure to check spec. So if those specs are correct on plate and cover its out of spec on the case side?Cause I'd just assumed the rotary cover and plate were correct cause new. If it is the case side that's out of spec can I give sbt the measurements and have a "special" rotary cover cut, to bring it into spec as opposed to machining the case side? Thanks for you time.
    Cte

  8. #8
    Joined
    Jul 2017
    From
    Texas
    Posts
    6

    Default Re: 2003 Seadoo GTI LE Problems

    Next question you gave me the measurements for a perfect brand new motor. Metal on metal stuff does wear, so there should be a range on the rotary valve? From new motor-slightly used- heavily used motor- wore the hell out motor. Do you have those acceptable ranges to give me a ballpark? I didn't machine cases,
    Thanks again,
    Cte

  9. #9
    Joined
    Jul 2017
    From
    Texas
    Posts
    6

    Default Re: 2003 Seadoo GTI LE Problems

    Clearence on rotary cover, valve, case good. Once I reinstalled everything w/o gasket per Manuel and measured had .011 clearence between rotary cover and plate. However noticed crank case oil was contaminated with water aka milky oil. Going back to double check my heads and head gaskets, crank seals. Any other suggestions?
    Cte

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 Yamaha xlt 1200 starter problems
    By Bquick4009 in forum Yamaha
    Replies: 2
    Last Post: 07-13-2010, 03:17 PM
  2. 2003 GTX 4-TEC - Fuel Pump Problems
    By spiper in forum Sea-Doo
    Replies: 0
    Last Post: 05-20-2009, 05:31 PM
  3. 2003 gtxdi compressor problems
    By shooke in forum Sea-Doo
    Replies: 4
    Last Post: 09-04-2008, 01:05 PM
  4. 2003 Seadoo GTI LE
    By auburngirl1024 in forum Sea-Doo
    Replies: 1
    Last Post: 02-20-2006, 08:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •