SBT Jetski Engines, Parts & Accessories

Results 1 to 3 of 3
  1. #1
    Joined
    Oct 2013
    From
    King George VA
    Posts
    7

    Default Yamaha 2003 800XLT loading problem

    Hi, I need some advice/help. I rebuilt the carburetors and pressure tested pop off with no problems. Did not replace gasket to engine nor the two gaskets outside the carbs. My problem: when start the jet ski it starts at max RPM's, very scary, no throttle just runaway engine. I think it is getting too much air somewhere because I can slow or stop runaway with max choke. My question what causes this run away problem? Where is it getting the gas? And where would the air leak most likely be? Any help would be appreciated. Dave Lane, King George VA

  2. #2
    Joined
    Jun 2016
    From
    Clearwater, Florida
    Posts
    278

    Default Re: Yamaha 2003 800XLT loading problem

    Check the throttle shafts to see if they are loose in the carb housing.

  3. #3
    Joined
    Oct 2013
    From
    King George VA
    Posts
    7

    Default Re: Yamaha 2003 800XLT loading problem

    OK I am embarrassed. I figure out my problem thanks to rodsatheart. In hooking up the throttle, I put the connector in the back hole which made the throttle tight without slack. After putting the connector in the front hole and loosening up the connector, the jet ski worked just fine. Much thanks to all. Dave

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 ZXI Jet Ski Electrical Problem
    By millerse in forum Kawasaki
    Replies: 2
    Last Post: 05-06-2009, 04:14 PM
  2. Breaking in a 800xlt with oil blockoff
    By pcsummit in forum Yamaha
    Replies: 1
    Last Post: 07-06-2007, 09:49 AM
  3. 2003 Sea-Doo GTX Check Engine problem
    By iolaus in forum Sea-Doo
    Replies: 0
    Last Post: 06-17-2007, 03:39 PM
  4. 2003 GTX sc cavitation problem
    By Terry Coolidge in forum Sea-Doo
    Replies: 13
    Last Post: 04-07-2005, 04:44 PM
  5. Problem with 2003 GTX SC oil message
    By theduke1997 in forum Sea-Doo
    Replies: 2
    Last Post: 07-17-2004, 05:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •