SBT Jetski Engines, Parts & Accessories

Results 1 to 8 of 8

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Joined
    Jun 2018
    From
    Reisterstown Md
    Posts
    94

    Default 95 sts 750 impeller shaft spinning after much debris in the river. Logs sticks bark s

    While crossing the Potapisco river debris in the river multiplying until 750 sts started losing propulsion. Turned around and limped back to boat ramp keeping rpms at under 4x . anything over that the impeller just spinning. Made the mile and a half back. Pulled pwc from water and see sea grass inside jet pump. although nothing noticeable at grate intake? If impeller gets filled with debris what is possibly broke and how should I troubleshoot it. I never turned off ski to reset anything could my Sts 750 have put itself in limp mode because it never overheated just would not propell the pwc beyond 4x rpms . Please tell me what to check first? Should I have restarted the ski to see if propeller is turning when wick is pulled over 4x rpms? please respond

    Sent from my SM-J700T1 using Tapatalk

  2. #2
    Joined
    May 2018
    From
    Lake Travis, Texas
    Posts
    8

    Default Re: 95 sts 750 impeller shaft spinning after much debris in the river. Logs sticks ba

    Start by removing the sea weed then check the impeller for any dings or cracks or bends, and then check the wear ring for scratches. Iím thinking the seaweed was probably causing a significant amount of cavitation at high rpms, and if the impelled is clean it should work fine after all the seaweed removed


    Sent from my iPhone using Tapatalk

  3. #3
    Joined
    Jun 2018
    From
    Reisterstown Md
    Posts
    94

    Default Re: 95 sts 750 impeller shaft spinning after much debris in the river. Logs sticks ba

    Is there a wear ring in a 1996 Kawasaki sts 750?

    Sent from my SM-J700T1 using Tapatalk

  4. #4
    Joined
    May 2018
    From
    Lake Travis, Texas
    Posts
    8

    Default Re: 95 sts 750 impeller shaft spinning after much debris in the river. Logs sticks ba

    I have no idea, if it were mine I would definitely start with removing the seaweed and seeing if that helps or solves it. I donít know if it has a wear ring, Iíve never actually seen one of these skis.... I would start simple and if the simple things donít fix it then go from there


    Sent from my iPhone using Tapatalk

  5. #5
    Joined
    Jun 2018
    From
    Reisterstown Md
    Posts
    94

    Default Re: 95 sts 750 impeller shaft spinning after much debris in the river. Logs sticks ba

    Thank you. I limped back and have not restarted it yet. Maybe it put itself in limp mode. but anything over 4x rpm was cavitation. spinning. Worst case is stripped splines. Thank for your Good words.I was at Calvert cliffs yesterday. Picked up a 2001 rx D.I hull with everything except engine and jet pump..

    Sent from my SM-J700T1 using Tapatalk

  6. #6
    Joined
    May 2018
    From
    Lake Travis, Texas
    Posts
    8

    Default Re: 95 sts 750 impeller shaft spinning after much debris in the river. Logs sticks ba

    I donít think it would be limp mode if it could still go above 4K rpms but would just cavitation at that speed. Limp mode would be more likely if the engine was overheating and it was limiting the rpms to 3-4K without being able to go any higher because it was trying not to overheat any worse...


    Sent from my iPhone using Tapatalk

  7. #7
    Joined
    Jun 2018
    From
    Reisterstown Md
    Posts
    94

    Default Re: 95 sts 750 impeller shaft spinning after much debris in the river. Logs sticks ba

    I did as you suggested. Thank you. I had a plastic bottle cap stuck on the impeller blade. Pulled it off. Hooked up flush hose. All clear. could that have caused the cavitation? We were about 100 yards away from fort Mchenry. its like a mine field in that area. logs trash everywhere. A bad choice that could have cost a bundle.thanks for reminding me to keep it simple and look for obvious reasons first

    Sent from my SM-J700T1 using Tapatalk

  8. #8
    Joined
    May 2018
    From
    Lake Travis, Texas
    Posts
    8

    Default Re: 95 sts 750 impeller shaft spinning after much debris in the river. Logs sticks ba

    I had a small twig cause huge cavitation with my ski so I wouldnít doubt a bottle cap causing issues. If you havenít already you might look into installing a strainer in your engines water intake to keep some trash from clogging cooling if trash is a big issue on your riding area... thereís an argument for it and against it so read up on it before you do it.


    Sent from my iPhone using Tapatalk

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ďDebris CleanoutĒ access plug removal
    By Frankjr57 in forum Yamaha
    Replies: 2
    Last Post: 06-22-2010, 09:19 AM
  2. steering sticks on my 94 750 sl
    By adams95 in forum Polaris
    Replies: 1
    Last Post: 06-13-2006, 11:24 AM
  3. 94 sp impeller shaft
    By ryan a in forum Sea-Doo
    Replies: 1
    Last Post: 06-19-2005, 08:08 PM
  4. Debris in pump......again
    By BertinTexas in forum Sea-Doo
    Replies: 1
    Last Post: 08-23-2004, 12:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •