SBT Jetski Engines, Parts & Accessories

Results 1 to 2 of 2
  1. #1
    Joined
    Jul 2011
    From
    Farmville VA
    Posts
    2

    Unhappy 95 spi not starting

    I have two 1995 seadoo spi skis. 587 engines. Rebuilt carbs again for the season and both were running great. One died in the water. No sputtering. Just flat out died. I have been working on it but must be missing something. I have spark. I have fuel enough to wet the plugs. The motor cranks but NEVER & I mean NEVER has fired again since the day it quit on the water. Since I have its twin on the dock, I have changed computer modules. No luck and the twin will run on the changed module. Have swapped plugs as well. I have tried starting fluid into the carb and directly into the cylinder with no luck. Never once fires. What am I missing? I called SBT tech guys today and he suggest to check compression and I thought he said reed valve cover if I wanted to remove the engine. Now that I have been googling information it appears he might be talking about the rotary valve cover. If so, I think it can be removed in the ski. Info indicated this can make a ski run poorly and if bad enough not run at all. However, wouldn't I have notice poor performance before it wore to the point of no start? I haven't put a compression tester on the cylinders yet but they have enough to blow my finger off as hard as i can hold it on. I know that doesn't mean much and I will check the compression. But for either of these two suggestions to be the culprit it seems to me I would have noticed poor performance prior to the ski dyeing. The ski was running great for several days prior to it dyeing. I have never known a motor to simply never fire again when it has spark, fuel and air. Unless maybe it is firing at the wrong time. But even then it should backfire or do some violent things. Help PLEASE!

  2. #2
    Joined
    Jul 2011
    From
    Farmville VA
    Posts
    2

    Default Re: 95 spi not starting

    What the heck is all this jap stuff replys?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. starting
    By jerry m in forum Sea-Doo
    Replies: 15
    Last Post: 12-23-2009, 02:18 PM
  2. Starting an old old ski
    By macedonia64 in forum Kawasaki
    Replies: 0
    Last Post: 07-26-2007, 10:39 AM
  3. starting the new 650
    By kenlawn in forum Yamaha
    Replies: 2
    Last Post: 03-31-2006, 09:45 AM
  4. 750 SX Hard Starting Starting
    By mfmcculla in forum Kawasaki
    Replies: 1
    Last Post: 03-02-2006, 01:30 PM
  5. GTX Not Starting
    By Seadoo1781 in forum Sea-Doo
    Replies: 4
    Last Post: 06-27-2003, 01:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •