SBT Jetski Engines, Parts & Accessories

Results 1 to 2 of 2
  1. #1
    Joined
    Jun 2001
    Posts
    8

    Post

    I bought a new battery at the beginning of the year. It worked great the first day I took it out, but after sitting for 3 weeks it was completely dead. It wouldn't even hold a charge. I took it back, got a new one, and the same thing is happening. Any idea what would cause the battery to drain that completely????

  2. #2
    Joined
    Feb 2001
    From
    Clearwater, FL
    Posts
    7,358

    Post

    The first thing I would suspect is that your rectifier (AC to DC converter) is not working on your ski.

    Put a voltage meter on your battery while the ski is running. If it doesn't read 13.5v, you have a problem.

    If that reads fine, then you have a drain somewhere while your ski is off.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. instrument cluster dead '02 4-tec
    By pstewart in forum Sea-Doo
    Replies: 1
    Last Post: 04-05-2006, 11:44 PM
  2. Polaris slxh dead - does not starts
    By jcisneros in forum Polaris
    Replies: 1
    Last Post: 07-21-2005, 09:39 PM
  3. Need more ultra 150 help, dead starter?
    By jordanmills in forum Kawasaki
    Replies: 14
    Last Post: 03-23-2005, 08:47 PM
  4. batteries
    By frankey01 in forum Sea-Doo
    Replies: 5
    Last Post: 07-06-2004, 11:48 AM
  5. My 97 GSX is Killing Batteries
    By CGOULD in forum Sea-Doo
    Replies: 1
    Last Post: 06-27-2004, 03:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •