SBT Jetski Engines, Parts & Accessories

Results 1 to 4 of 4
  1. #1
    Joined
    Jun 2003
    Posts
    7

    Post

    Here's the story:

    Had the ski out on the lake last weekend and everything was fine until about 2 hours into riding it. Shut it off via the start/stop switch while sitting in one placing talking to someone for about 10 minutes then tried to start it up and seemed like low battery (starter was barely trying to turn over).

    I had it towed back to shore and took it back home where I replaced the battery with a brand new one and it would start but only run at idle. As soon as the throttle is pushed at all it will stall. Figured I had a fuel problem so I replaced the fuel filter, checked the fuel switch which was fine, and also replaced the plugs (they were not fouled but were very black).

    Well to make a long story short, it still will start and idle for about 30-60 seconds and then stall and also stalls no matter what if I give it any throttle.

    Any suggestions would be greatly appreciated!!!

  2. #2
    Joined
    Mar 2003
    From
    SBT
    Posts
    21,545

    Post

    I would pull your carbs - your needle & seats may be shot.
    SBT Tech Support is here to help with your problems.
    We try to answer each question quickly and accurately.
    Please do not use Private Messaging for Tech Support, use the forums.

  3. #3
    Joined
    Jun 2003
    Posts
    7

    Post

    They look ok to me, should I replace them just to be safe? Anything else I should be looking for?

    Thanks for the help!

  4. #4
    Joined
    Feb 2001
    From
    Glendora, Ca.
    Posts
    5,204

    Post

    I would try a new rectifier. The battery was low, which means it is bad or not getting a charge when riding (rectifier controls that). When a rectifier is bad, the ski won't rev up.
    Bill O'Neal WCM
    <a href="http://www.watercraftmagic.com" target="_blank">www.watercraftmagic.com</a>

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 SeadDoo GTX RFi Starting Problems
    By Robert Willis in forum Sea-Doo
    Replies: 7
    Last Post: 06-26-2006, 09:25 AM
  2. 96 GTX Starting Problems
    By ILikeMyBu in forum Sea-Doo
    Replies: 1
    Last Post: 04-02-2006, 08:15 PM
  3. 1992 GTX starting problems
    By sprinter10m in forum Sea-Doo
    Replies: 4
    Last Post: 09-08-2005, 02:04 PM
  4. 96 GTX Starting Problems
    By cole1247 in forum Sea-Doo
    Replies: 25
    Last Post: 07-18-2005, 06:31 PM
  5. Replies: 2
    Last Post: 06-01-2005, 04:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •